28 October 2013

Тихо и незаметно вышла первая стабильная версия pylint. pylint - это статический анализатор Python-кода, который можно интегрировать разные IDE, например в Eclipse.

Правда радость выхода новой версии, огорчается тем, что в новой версии отсутствует параметр командной строки --include-ids, который используется в PyDev. Из-за этого ломается отображение сообщений об ошибках в рабочей области Eclipse. На Stackoverflow эту тему уже успели обсудить тут и тут.

Что бы вернуть корректоное отображение сообщений вместе с их ID, необходимо зайти в Eclipse в Preferences -> PyDev -> PyLint и добавить следующий аргумент в параметры запуска pylint:

--msg-template='{msg_id}:{line:3d},{column}:{msg}'

Этот параметр поменяет формат вывода сообщений, на старый.



blog comments powered by Disqus

Fork me on GitHub